Cut Harness 2007 fz6 code 19

Fz6 2007

New Member
Code 19 after attempted theft, rewired the harness and bypassed side stand switch . I have cleared at diagnosis 62 after , but still coming back...cranks but no fire .. anybody got a wiring diagram for this ? thanks ... any ideas...
 

Attachments

Fz6 2007

New Member
I have another question, at 62 in Yamaha diagnostic ...60 says 0 and 61 used to say 19, but not now... still won't start but turns over good, nur
tral light comes on while in neutral... still no start... when I get to 62 I have been able to clear by cycling kill switch
... But not now... any ideas to solve this... please help if you can... it's a daily driver before it was stolen and hacked up
 

Fz6 2007

New Member
Also just in case there's a connection with this problem, my brake light doesn't work with either the hand or foot brake applied ... just trying to provide all things that could be related ... Any Thoughts?
 

Fz6 2007

New Member
So I press both select and reset ,then turn key on ... Wait 8 seconds or so: then do it again for like 4seconds . The screen goes to Yamaha SELF DIAGNOSIS...d1 is throttle...etc
At d62 I should be able to reset/clear a code...by cycling kill switch?... This is where I get lost , how to clear in d62... currently d62 reads 1& d61 used to read 19 and d60 used to read 1... Disconnected battery
...now d60 is 0, d61 is 0 but d62 is 1....
Help... Thanks !!
 

Fz6 2007

New Member
h electronic fuel injection.
******************************** 01 : Throttle position - must be from 15-17 (closed) to 97-100 (opened) 02 : Atmospheric pressure given in mmHg (normal is 760 - average weather) 03 : Differential pressure between air and intake pipe 05 : Air intake temperature (in Celcius) 06 : Cooling liquid temperature (in Celcius) 07 : Absolute speed (must be 000 in garage). Check with rear weel. 08 : Lean angle safety switch control - must be from 0.4-1.4 (upright) to 3.8-4.2 (horizontal). DISMOUT THE SWITCH FOR CHECKING !!! 09 : Battery voltage - must be above 12.0 20 : Side stand switch - displays ON or OFF 21 : Neutral gear switch - displays ON or OFF Part II : ECU memory check. 60 : EEPROM error code presence - 00 means no default, 01 or 02 means default on corresponding cylinder (blinks if both cylinders). 61 : Error Code memory log - Displays 00 if no error code in memory, displays the Error Code if any (11 to 50). Display changes every two seconds if more than one Error Code in memory, then start again from first. 62 : Displays the number of Error Code in memory. To clear the memory, switch the Engine Run Switch to ON position (no backup). 70 : Check Code number, display from 0 to 255 Part III : Activators - To activate, turn Engine Run switch from OFF to ON - Engine check light is activated too. 30 : Coil 1 is activated 5 times per second. 31 : Coil 2 is activated 5 times per second. 36 : Injector 1 solenoid is activated 5 times per second. 37 : Injector 2 solenoid is activated 5 times per second. 48 : Air duct solenoid is activated 5 times per second. 49 : Air intake solenoid is activated 5 times per second. 50 : Fuel injection relay is activated 5 times per second. 51 : Cooler fan is activated every 5 seconds. 52 : Headlight relay is activated every 5 seconds (2 seconds ON, 3 seconds OFF) - 2003+ model only. Error Codes Error Number 11 : Cylinder identification sensor error - DIAG mode (none) Error Number 12 : Crankshaft posiiton sensor error - DIAG mode (none) Error Number 13 : Air intake pressure sensor error - DIAG mode 03 Error Number 14 : Air intake duct error - DIAG mode 03 Error Number 15 : Throttle position sensor error - DIAG mode 01 Error Number 19 : Sidestand sensor error - DIAG mode 20 Error Number 20 : Air pressure sensors error - DIAG mode (none) Error Number 21 : Coolant temperature sensor error - DIAG mode 06 Error Number 22 : Air intake temperature sensor error - DIAG mode 05 Error Number 23 : Ambient air pressure sensor error - DIAG mode 02 Error Number 24 : O2 (lambda) sensor error - DIAG mode (none) Error Number 30 : The bike went down - DIAG mode 08 Error Number 33 : Coil 1 open circuit - DIAG mode 30 Error Number 34 : Coil 2 open circuit - DIAG mode 31 Error Number 41 : Tilt sensor error - DIAG mode 08 Error Number 42 : Speed sensor error / Neutral sensor in short-circuit - DIAG mode 07-21 Error Number 43 : Battery voltage control error - DIAG mode (none) Error Number 44 : EEPROM read/write error - DIAG mode 60 Error Number 50 : ECU memory error - DIAG mode (none) Error Er-1 : ECU link error Error Er-2 : ECU link error Error Er-3 : ECU link error Error Er-4 : ECU link error Following ERROR codes DO NOT allow engine to run : 11-12-19-30-41-50 and Er-1 to Er-4 Error code 11 allow engine to continue running only if fault appears after engine start. Following ERROR codes DO allow engine to run but need immediate check because default values are taken by the ECU: 13-14-20-21-22-23-24-24-42-43-44 *....
Is what I find so far... searching...:)
 

Fz6 2007

New Member
https://www.600riders.com/forum/fz6-technical/3131-fault-codes-listed-fz6-service-manual.html
This sticky says fault code 19 is not about side stand switch but about no4 ECU connection/circuit ...this sounds more like my problem- With cut harness... I've cleaned the contacts in the side stand switch... nothing... I've bypassed the side stand switch and even disconnected it ... Still nothing...
What next... any body know where the no4 ECU wire goes so I can test it's continuity ???
BTW it's an 07 (production date 12/06 ) FZ6 VIN:JYARJ13E47A002027
Help :)
 
Last edited:

Gary in NJ

Junior Member
Site Supporter
I feel bad you, posting with no answers.

From my understanding non-US spec FZ's have an immobilizer on the ignition circuit and the ignition switch itself that requires a key with a magnetic insert. Because of this I've heard that the inexpensive replacement switches on eBay don't work on non-US spec bikes. With that said, perhaps the immobilizer circuit is present in US spec bikes to keep someone from hacking into the harness with an external ignition switch. Once the circuit is opened the ECU may require a reset.

If no one chimes in soon, perhaps a visit to a local Yamaha dealer would yield a result. I'd bring the title of the bike with you as without it questions about a hacked wire harness may seem suspect.
 

Motogiro

Vrrroooooom!
Super Moderator
Moderator
Elite Member
Site Supporter
What color is the #4 wire to the ECU you reference? The documentation does not list a wire number in the schematic.

Are you lacking spark, fuel delivery or both? When you turn the key to on do you get the fuel pump priming sound?

When I hear the FZ6 starter spins but the engine won't fire I also think of the lean angle switch.
 
Last edited:

Fz6 2007

New Member
Cliff , when. I try to start the motor , I hear the fuel pump...and in diagnostic mode I see the Lean angle is good...I dunno the no.4 wire color but in the wiring diagram it shows it's also circuit will kill switch, lean angle and side stand switch ..
 
Last edited by a moderator:

Motogiro

Vrrroooooom!
Super Moderator
Moderator
Elite Member
Site Supporter
The diagram you've pictured is the side stand switch. It is tied through the "Starter circuit cut-off relay" That assembly has the safety logic the looks at the neutral safety switch, clutch switch and side stand switch. It is looked at by the ECU which can shut off the fuel injection, ignition and starter function.

Most often this assembly is compromised and the diodes are damaged when there is an attempted theft by cutting the harness. It's almost like it was designed to fail during an attempted theft. The good thing is if this happened it cost a little under $40 to keep it from going anywhere. Any shorting of those harness wires can cause this assembly to go bad.

The one thing that I wonder about is, why does the starter crank? If this relay assembly is bad (not the starter relay) there should be no starter operation. Also if this circuit is at fault you should not hear the fuel pump prime. This leads me to believe the circuit is operating properly.
 

Fz6 2007

New Member
Cliff, starter circuit cut off relay ... I will try to locate that relay test in that service manual... thanks
I just cleaned the kill switch and still cranks, no start...there was one fuse blown when I got it back but I've replaced it and it's not blown again ...nuetral switch itself seems to work ( light in nuetra out in gear)...
Thanks Cliff I will look into that relay you've discussed
 

Fz6 2007

New Member
View attachment 69502
Recall that the wires cut were at the main switch (1) and I attempted to repair those first ...I have yet to locate and check the backup fuse (4) ...
Does anyone know where that backup fuse is (Cliff . :). .) ??? Could this be where the open circuit is ... because it does turn over, fuel pump active
..then "19" is on the display as soon as key is put in ON position...
hehehehe..lots of challenges , almost wish police never recovered it .... hehehehe
 
Last edited by a moderator:

Fz6 2007

New Member
Cliff do you think that backup fuse is the one of two at starter relay ...I may have accidentally found and replaced it at day 1 ?
And I get it about copyright diagram ... no worries
 

Motogiro

Vrrroooooom!
Super Moderator
Moderator
Elite Member
Site Supporter
Cliff do you think that backup fuse is the one of two at starter relay ...I may have accidentally found and replaced it at day 1 ?
And I get it about copyright diagram ... no worries
I think the back up fuse is the clock. Never hurts to pop each fuse and ohm each one out to insure you haven't lost a branch. You did say your brake light was out. Sure it's not the bulb? Does your horn work? No......... I'm not being a wise ass. The horn and brake light circuit are on the same fuse.
 
Last edited:

Fz6 2007

New Member
I think the back up fuse is the clock. Never hurts to pop each fuse and ohm each one out to insure you haven't lost a branch. You did say your brake light was out. Sure it's not the bulb? Does your horn work? No......... I'm not being a wise ass. The horn and brake light circuit are on the same fuse.
Checked all fuses w/key on engine off,all had hot 12.7v on both sides... even the tail light fuse.
The bulb was blown in tail light, I replaced it now it operates...yes the horn works also...
I guess I will rig
a power probe and begin to test the starting cut-off relay as per the 07 service manual...
Cliff, ya said something about the cut off relay being bad , it shouldn't turn over or fuel pump activation... what's your next thought?...
Thanks Again !!
 

Fz6 2007

New Member
Checked all fuses w/key on engine in off,all had hot 12.7v on both sides... even the tail light fuse.
The bulb was blown in tail light, I replaced it now it operates...yes the horn works also...
I guess I will rig
a power probe and begin to test the starting cut-off relay as per the 07 service manual...
Cliff, ya said something about the cut off relay being bad , it shouldn't turn over or fuel pump activation... what's your next thought?...
Thanks Again !!
IMG_20181122_110714.jpg
IMG_20181122_110714.jpg
Cliff, I tested as per and when power is supplied to 1&2grounded...
I hear a relay click but never get continuity at 3&4...that fails as per my understanding.
I do hear it click and it never drew enough amps to trip my power probe protection circuit...
Does the starting circuit ut-off relay ever fail but yet still crank and fuel pump activation?
The test for the starting circuit cut-off relay is at 8-71 of the 07 service manual...and
Have a great Tday everyonethat special test is what I performed, resulting only in noise but never continuity !!!
 
Last edited:

Fz6 2007

New Member
Screenshot_20181122-174738.jpg

Also here is the info refercing the no.4 circuit at ECM...
Copied from the sticker re codes by admin ...
Is this something to research ?
Thanks All...
Happy Tday...!!!
 
Top